블로그 이미지
초딩입맛제주아재
하고 싶은 것만 하며 살고 싶다

calendar

      1 2 3 4
5 6 7 8 9 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30 31  
2007. 12. 7. 18:33 카테고리 없음
출처: http://bclary.com/2004/08/27/javascript-version-incompatibilities


아래의 코드를 실행하면 해당 브라우저에서 지원하는 javascript 코드를 확인 할 수 있다.

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Determine JavaScript Version</title>
<style type="text/css">
html, body { margin: 0; padding: 0}
</style>
<script language="javascript">
var jsversion = 1.0;
</script>
<script language="javascript1.1">
jsversion = 1.1;
</script>
<script language="javascript1.2">
jsversion = 1.2;
</script>
<script language="javascript1.3">
jsversion = 1.3;
</script>
<script language="javascript1.4">
jsversion = 1.4;
</script>
<script language="javascript1.5">
jsversion = 1.5;
</script>
<script language="javascript1.6">
jsversion = 1.6;
</script>
<script language="javascript1.7">
jsversion = 1.7;
</script>
<script language="javascript1.8">
jsversion = 1.8;
</script>
<script language="javascript1.9">
jsversion = 1.9;
</script>
<script language="javascript2.0">
jsversion = 2.0;
</script>
</head>
<body>
<div>
<script language="javascript">
document.write('Your browser claims to support JavaScript ' + jsversion)
</script>
</div>
</body>
</html>
posted by 초딩입맛제주아재

댓글을 달아 주세요

  1. 제오니 2007.12.21 10:19  Addr Edit/Del Reply

    자스 버전이 크게 중요한가?
    거진 일괄적이지 않나???

  2. 오오!~ 알고싶은 건되 알게되내요...
    확인 하는 방법은 생각외로 단순하내요!~